进程监控另类方法
欢迎来到南池岸边!书写倾听属于自己的故事

进程监控另类方法 api进程监视

我们在写某些小工具的时候可能需要监视别的进程直到退出,虽然可以使用时钟不断的读取判断,缺点也很明显,会造成系统卡顿。

所以读取了很多文献后发现两个API轻松搞定

两个API分别是:

WaitForSingleObject

OpenProcess

.版本 2



.DLL命令 打开进程_, 整数型, "kernel32.dll", "OpenProcess", , 将句柄返回给过程对象

    .参数 进程对象, 整数型, , dwDesiredAccess

    .参数 继承句柄, 整数型, , bInheritHandle

    .参数 进程标识符, 整数型, , dwProcessId



.DLL命令 API_WaitForSingleObject, 整数型, "kernel32", "WaitForSingleObject", , 监测一个对象

    .参数 hHandle, 整数型

    .参数 dwMilliseconds, 整数型
.版本 2



.子程序 等待, , , 等待进程退出

.参数 进程ID

.局部变量 句柄, 整数型



句柄 = 打开进程_ (2035711, 0, 进程ID)

API_WaitForSingleObject (hProcess, -1)

信息框 (“程序已经退出”, 0, , )

这时我们在调用监控指定的进程就会发现CPU几乎没有任何影响了

扫码支持
未经允许不得转载:南池岸边 » 进程监控另类方法


您的支持是我更新下去的动力

支付宝扫一扫打赏

微信扫一扫打赏